Static NAT Redundancy

HSRP

در شکل فوق روتر ۲ و روتر ۳ را بعنوان Default Gateway  برای روتر های ۱ و ۴ کانفیگ شوند  روتر ۲ بعنوان Primary default gateway باشد و روتر ۳ بعنوان Backup اگر روتر ۲ Down شد روتر ۳ Primary شود و اگر روتر ۲ UP شد دوباره بعنوان Primary شود . زمانی که روتر ۱ درخواست برقراری ارتباط با روتر ۴ را داشت ip 10.1.1.1/24 با ip 192.1.1.1  NAT شود و فقط روتر Primary می تواند NAT را انجام دهد

R2
interface fa 1/0
standby 1 ip 10.1.1.100
standby 1 name HSRP-1
standby 1 priority 110
standby 1 preempt
standby 1 track fastethernet 1/1 50

interface fa 1/1
standby 2 ip 200.1.1.100
standby 2 name HSRP-2
standby 2 priority 110
standby 2 preempt
standby 2 track fastethernet 1/0 50

R1
ip route 0.0.0.0 0.0.0.0 10.1.1.100

R3
interface fa 1/0
standby 1 ip 10.1.1.100
standby 1 name HSRP-1
standby 1 preempt

interface fa 1/1
standby 2 ip 200.1.1.100
standby 2 name HSRP-2
standby 2 priority 100
standby 2 preempt

R4
ip route 0.0.0.0 0.0.0.0 200.1.1.100

روتر ۲ بعنوان Active و روتر ۳ Standby

R2#show standby brief
Interface Grp  Pri P State   Active          Standby         Virtual IP
Fa1/0     ۱    ۱۱۰ P Active  local           ۱۰٫۱٫۱٫۳        ۱۰٫۱٫۱٫۱۰۰
Fa1/1     ۲    ۱۱۰ P Active  local           ۲۰۰٫۱٫۱٫۳       ۲۰۰٫۱٫۱٫۱۰۰

R3#show standby brief
Interface Grp  Pri P State   Active          Standby         Virtual IP
Fa1/0     ۱    ۱۰۰ P Standby 10.1.1.2        local           ۱۰٫۱٫۱٫۱۰۰
Fa1/1     ۲    ۱۰۰ P Standby 200.1.1.2       local           ۲۰۰٫۱٫۱٫۱۰۰

کانفیگ NAT را در روتر های ۲ و ۳ را انجام میدهیم

R2&R3
interface fastethernet 1/0
ip nat inside

interface fastethernet 1/1
ip nat outside

ip nat inside source static 10.1.1.1 192.1.1.1 redundancy HSRP-1

                 ۱  R1#ping 200.1.1.4 repeat

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 200.1.1.4, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 76/76/76 ms

R2#deb ip nat
IP NAT debugging is on
May  ۴ ۱۶:۳۶:۱۷٫۵۴۳: NAT*: s=10.1.1.1->192.1.1.1, d=200.1.1.4
May  ۴ ۱۶:۳۶:۱۷٫۶۰۷: NAT*: s=200.1.1.4, d=192.1.1.1->10.1.1.1

حال روتر ۲ را غیر فعال میکنیم

R2
interface fastethernet 1/0
shutdown

R1#ping 200.1.1.4 repeat

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 200.1.1.4, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 76/76/76 ms

R3#deb ip nat
IP NAT debugging is on
May  ۴ ۱۶:۴۰:۲۵٫۹۶۷: NAT*: s=10.1.1.1->192.1.1.1, d=200.1.1.4
May  ۴ ۱۶:۴۰:۲۶٫۰۰۷: NAT*: s=200.1.1.4, d=192.1.1.1->10.1.1.1

Leave a comment ?

۴ Comments.

  1. سلام من تازه وارد دنیای سیسکو شدم خیلی هم گیج شدم نمیدونم باید چه کار کنم کلاس ccnp route & switch هم رفتم ولی هنوز خیلی چیزارو بلد نیستم به نظر شما بازم کلاس برم یا خودم کتاب بخونم . راهنمایی کنید متشکرم

    • سلام دوست عزیز
      بهتره که خودتان کتاب را بخوانیدوتا مبحثی را درک نکردیدمبحث بعدی را نخوانید
      سعی کنیدازمقالات موجوددراینترنت استفاده کنیدبیشرازمقالات زبان اصلی استفاده کنید
      هر چنددوستان عزیزی هستند که مقالاتی به فارسی نوشته اند
      http://forum.ciscoinpersian.com
      درقسمت پرسش و پاسخ هم می توانید سوالات خودتان رامطرح کنید تاجایی که بتوانم دریغ نمی کنم

  2. با سلام و تشکر.۱۰٫۱٫۱٫۳ رو کجا به روتر۲ میدیم؟؟م ❗

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>