OSPF Non-Broadcast Networks

Ospf

R1

router ospf 1

network 1.1.1.1 0.0.0.0 area 0

network 10.1.1.1 0.0.0.0 area 0

R2

router ospf 1

network 2.2.2.2 0.0.0.0 area 0

network 10.1.1.2 0.0.0.0 area 0

R3

router ospf 1

network 3.3.3.3 0.0.0.0 area 0

network 10.1.1.3 0.0.0.0 area 0

R4

router ospf 1

network 4.4.4.4 0.0.0.0 area 0

network 10.1.1.4 0.0.0.0 area 0

R1#sh ip ospf neighbor

همسایگی روتر ها چک می کنیم می بینیم که روتر ها با هم همسایه نشده اند

Network type را بررسی میکنیم

 

R1#sh ip ospf interface serial 1/0

Serial1/0 is up, line protocol is up

Internet Address 10.1.1.1/24, Area 0

Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64

بصورت پیش فرض Network Type در محیط Multipoint Frame-Relay

اینتر فیس Network Type NON_BROADCAST است

در این حالت روتر ها نمی توانند از Broadcast یا Multicast استفاده کنند

Ospf هم برای همسایه شدن از Multicast استفاده میکند

بنابراین روتر ها با هم همسایه نمی شوند برای ایجاد همسایگی روتر ها باید از دستو Neighbor استفاده کنیم

در این حالت ospf از unicast برای همسایه شدن استفاده میکند

نکته : در حالت NON_BROADCAST انتخابات DR/BDR انجام میشود

با دستور۰ ip ospf priority تعیین میکنیم که R2-R3-R4 هیچ وقت بعنوان DR یا BDR انتخاب نشوند

و R1 است که بعنوان DR انتخاب می شود  بصورت پیش فرض Priority 1 است

در R1 از دستور Neighbor استفاده میکنیم

نکته:کافیست این دستور را در Hub Router وارد مکنیم که در این توپولوژی R1 است

 

R1

router ospf 1

neighbor 10.1.1.2

neighbor 10.1.1.3

neighbor 10.1.1.4

%OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial1/0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/0 from LOADING to FULL, Loading Done

R1#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

۲٫۲٫۲٫۲ ۰ FULL/DROTHER 00:01:35 10.1.1.2 Serial1/0

۳٫۳٫۳٫۳ ۰ FULL/DROTHER 00:01:53 10.1.1.3 Serial1/0

۴٫۴٫۴٫۴ ۰ FULL/DROTHER 00:01:59 10.1.1.4 Serial1/0

R1#sh ip route ospf

O 2.0.0.0/8 [110/65] via 10.1.1.2, 00:06:07, Serial1/0

O 3.0.0.0/8 [110/65] via 10.1.1.3, 00:06:07, Serial1/0

O 4.0.0.0/8 [110/65] via 10.1.1.4, 00:06:07, Serial1/0

R2#sh ip route ospf

O 1.0.0.0/8 [110/65] via 10.1.1.1, 00:06:53, Serial1/0

O 3.0.0.0/8 [110/65] via 10.1.1.3, 00:06:53, Serial1/0

O 4.0.0.0/8 [110/65] via 10.1.1.4, 00:06:53, Serial1/0

R2 روت های R3 و R4 را Learn کرده است ولی نمی تواند به آنها دسترسی داشته باشد

R2#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

…..

Success rate is 0 percent (0/5)

دلیل چیست که نمی تواند به آنها دسترسی داشته باشد Debug میکنیم

 

R2#deb frame-relay packet

R2#ping 3.3.3.3

Serial1/0:Encaps failed–no map entry link 7(IP).

Success rate is 0 percent (0/1)

از نظر لایه دو نمی تواند به R3 دسترسی پیدا کند برای ایجاد دسترسی ازframe-relay map استفاده میکنیم

 

R2

interface Serial1/0

frame-relay map ip 10.1.1.3 201

frame-relay map ip 10.1.1.4 201

R3

interface Serial1/0

frame-relay map ip 10.1.1.2 301

frame-relay map ip 10.1.1.4 301

R4

interface Serial1/0

frame-relay map ip 10.1.1.3 401

frame-relay map ip 10.1.1.2 401

دوباره تست میکنیم

R2#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echo to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/47/96 ms

Leave a comment ?

۰ Comments.

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>