Q.in.Q Tunneling

 

 

 

 

فرض میکنیم که سویچ های ۱ و ۴ سمت مشترک هستند و سویچ های ۲ و ۳ Service Provider می باشند

Provider با یک پورت Access که عضو Vlan 100 است به مشترک متصل است

Provider از Vlan های مشترک اطلاعی ندارد(۱۴و۴۱) پس روتر ۴ با روتر ۱ نمی توانند با هم ارتباطی داشته باشند برای برقراری ارتباط روتر ها Provider از  Q.in.Q Tunneling استفاده میکند

R1
interface FastEthernet0/0
no shutdown
!
interface FastEthernet0/0.14
encapsulation dot1Q 14
ip address 14.0.0.1 255.255.255.0
!
interface FastEthernet0/0.41
encapsulation dot1Q 41
ip address 41.0.0.1 255.255.255.0
R4
interface FastEthernet0/1
no shutdown
!
interface FastEthernet0/1.14
encapsulation dot1Q 14
ip address 14.0.0.4 255.255.255.0
!
interface FastEthernet0/1.41
encapsulation dot1Q 41
ip address 41.0.0.4 255.255.255.0

SW1
system mtu 1504
!
interface FastEthernet0/1
switchport access vlan 100
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
no cdp enable
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport mode trunk

SW2
system mtu 1504
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport mode trunk
SW3
system mtu 1504
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
SW4
system mtu 1504
!
interface FastEthernet0/4
switchport access vlan 100
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
no cdp enable
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk

R4#show cdp neighbor
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater

Device ID   Local Interface Hold time Capability Platform Port ID
R1                  Fas 0/1               ۱۲۵                 R S I            ۲۶۱۰XM Fas 0/0

روتر ۴ روتر ۱ را Direct Connected میبیند یعنی در یک سویچ هستند

برای اطلاعات بیشتر http://www.mytips.ir/?p=686#more-686

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_13_ea1/configuration/guide/swtunnel.html

Leave a comment ?

۲ Comments.

  1. سلام
    ممنون از توضیحات خوبتون
    فرض کنیم مشترک یک روتر داره که به سوئیچ لایه دو پرووایدر وصله این کانفیگها رو میتونه روی روترش بزنه؟یا باید روی یک سوئیچ زده بشه و سوئیچ رو به روترش وصل کنه؟

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>