Router As Vpn Server

ما از روتر cisco میتوانیم بعنوان vpn server استفاده کنیم

ابتدا در روتر یک user می سازیم که vpn را تست کنیم (البته ما میتوانیم بجای اینکه در روتر user بسازیم از یک  Accounting استفاده کینم مثلاً Nttac + یا هر Accounting دیگر )

Router(config)# username test password 123

در این مرحله باید روتر کانفیگ کنیم که برای Authentication از user های Local خودش استفاده کند

Router(config)# aaa new-model

Router(config)# aaa authentication ppp default local

در این مرحله به Interface های روتر IP میدهیم

Router(config)# interface ethernet0/0

Router(config-if)# ip address 80.191.222.2 255.255.255.0

Router(config-if)# no shutdown

Router(config)# interface ethernet0/1

Router(config-if)# ip address 192.168.0.1 255.255.255.0

Router(config-if)# no shutdown

حال باید کانفیگ مربوط به vpn را در روتر انجام دهیم

Router(config)# vpdn enable

Router(config)# vpdn-group TEST-VPN

Router(config-vpdn)# accept-dialin

Router(config-vpdn)# protocol pptp

Router(config-vpdn)# virtual-template 1

Router(config-vpdn)# exit

Router(config)# interface Virtual-Template1

Router(config-if)# ip unnumbered Interface 0/1

Router(config-if)# peer default ip address pool VpnUsers

Router(config-if)# ppp authentication ms-chap   chap   pap

حالا یک Pool برای user های vpn میسازیم

Router(config)# ip local pool VpnUsers  ۱۹۲٫۱۶۸٫۰٫۱۰  ۱۹۲٫۱۶۸٫۰٫۳۰

منتظر نظرات شما عزیزان هستم

Leave a comment ?

۱ Comments.

  1. باسلام
    خیلی خوب بود اگه میشه را اندازی با nttac رو بطور دقیق با توضیح برای من ایمیل کنی ممنون میشم

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>